OpenRoads Designer CONNECT Edition SDK Help

Circle Methods

Methods

_IsClosed Indicates whether a LinearElement is closed. (Overrides LinearElement._IsClosed())
Accept Accepts this element (Overrides CircularArc.Accept(LinearElementVisitor))
CloneInternal Creates a copy of this instance (Overrides CircularArc.CloneInternal())
Create1  
CreateByCenterRadius Constructs a circle by cwenter and radius.
GetBestApproximatedArea(Double) Gets the area of a closed linear complex element
GetBestApproximatedArea(Double, Double) Gets the area of a closed linear complex element

See Also